• 0

  • 0

安装爬虫Scrapy遇到You should consider upgrading via the ‘pip install --upgrade pip‘ command问题解决

猿人不正经

不想写代码

1个月前

在Windows系统下使用pip安装scrapy的时候遇到了这个问题 ,安装爬虫的时候遇到的,导致安装失败pip install scrapy

You should consider upgrading via the 'pip install --upgrade pip' command

意思就是说应该考虑通过“pip安装——升级pip”命令进行升级,不然就使用pip安装不了,所以就按照它的提示对pip进行升级,
pip install --upgrade pip

按照要求执行完pip install --upgrade pip命令后依旧失败,后来发现是没有管理员权限的原因,右键以管理员身份运行就可以了。如果是在Linux系统下进行pip升级的话,就不会有这个权限问题了。

在这里插入图片描述

出现以上提示就说明升级成功!,然后再输入命令安装爬虫pip install scrapy,这个时候就耐心等待一会

在这里插入图片描述
这时就安装成功了!输入scrapy命令,查看版本
在这里插入图片描述
如上图所示,能看到scrapy信息,说明安装成功!

免责声明:文章版权归原作者所有,其内容与观点不代表Unitimes立场,亦不构成任何投资意见或建议。

0

相关文章推荐

未登录头像

暂无评论