• 0

  • 388

  • 收藏

以太坊基金会:信标链 Altair 主网升级公告

Unitimes

Unitimes官方账号

2星期前

撰文:Danny Ryan,以太坊研究员

编辑:南风

Altair 信标链升级已经准备好在以太坊主网上激活,此次升级将在 epoch 74240  (2021 年 10 月 27 日 UTC 时间上午 10:56:23) 上线。

客户端版本

为了与 Altair 升级兼容,信标节点运营者必须更新其运行的客户端版本。如果你运行一个验证者,你必须进行升级,以继续紧跟信标链主网。如果不升级,这将会导致你面临离线惩罚 (downtime penalties).

下面列出了支持主网 Altair 升级的各个客户端版本:

1) 客户端:Lighthouse

  • 版本号:v2.0.0

2) 客户端:Lodestar

  • 版本号:v0.31.0

3) 客户端:Nimbus

  • 版本号:v1.5.0

4) 客户端:Prysm

  • 版本号:v2.0.0

5) 客户端:Teku

  • 版本号:21.9.2

验证者的升级

尽管此次升级已经进行了广泛的测试,但如果你是信标链主网的一名验证者,我们强烈建议你在此次升级期间保持在线,以防出现任何不可预见的问题。

漏洞赏金

为了让此次 Altair 升级获得更多关注,从现在开始直至此次升级四周之后 (11月27日) 的这段时间,所有与 Altair 升级相关的漏洞赏金已经翻倍!现在,与客户端和规范相关的关键 Altair 漏洞的赏金都高达 10 万美元。更多细节请参考 Eth2 漏洞赏金计划:

https://ethereum.org/en/eth2/get-involved/bug-bounty/

FAQ (常见问题答疑)

>>作为以太坊用户或者 ETH 持有者,我需要做什么吗?

此次升级纯粹是对信标链共识机制的升级,并不会影响由以太坊 PoW 链保护的终端用户账户、合约和状态。

但如果你运行自己的信标节点,你需要升级你的节点。详情请查看下方“作为一名不运行验证者的信标节点运营者,我需要做什么?”这一小节。

>>作为一名不运行验证者的信标节点运营者,我需要做什么?

下载你运行的信标节点客户端的最新版本,见上文。

>>作为一名验证者,我需要做什么?

下载你运行的软件的最新版本,见上文。按照发布中的说明,使用标准的重启过程重新启动你的节点。

注意,支持独立验证者客户端的节点软件也需要升级和重启至该组件。请阅读官方发布公告中的警告和说明。

>>如果我是一名验证者或者节点运营者,但我并没有参与此次升级,将会如何?

如果你正在运行的信标节点客户端没有升级至最新版本,一旦此次升级发生,你的客户端将与此次分叉升级之前的那条信标链进行同步。你将会被困在一条遵循旧规则的不兼容链上。

如果你运行一个验证者,那么此验证者将无法参与到升级之后的共识中来,但会继续在升级之后的信标链网络上运行。这将导致此验证者面临升级后的主网链相关的惩罚。

>>信标链网络升级期间会发生什么?

在以太坊社区就升级中应该包含哪些更改达成共识之后,这些协议的更改将被写入各个客户端。对信标链协议的更改会在某个 epoch 号被激活。任何未升级至新规则集的节点将会被丢弃在旧链上,旧规则将可能继续在旧链上存在。

>>为何此次升级命名为“Altair”?

经过社区讨论和投票,各客户团队决定为每次升级使用恒星的名称,升级名称的顺序按字母顺序排列。

Altair (牛郎星) 以“A”开头,是夜空中第十二亮的恒星,自转速度非常快,赤道速度为286公里/秒。这是一颗很酷的恒星。

鸣谢!

非常感谢所有的研究人员、工程师和社区成员,他们为这首次信标链网络升级投入了大量工作。

现在,继续朝着合并之路前进🚀

免责声明

这是一个新兴的、不断发展的高技术领域。如果你选择执行这篇文章中的建议并继续参与,你应该确保你了解由此对你产生的影响。你应该了解其中包含的风险,包括但不限于意外 bugs 等风险。通过选择执行本文中的这些建议,风险自担。本文和其中的建议不构成任何形式的销售,也不构成任何形式的保证,包括但不限于任何与以太坊网络或本文提及的以太坊客户端相关的内容。

原文链接:

https://blog.ethereum.org/2021/10/05/altair-announcement/

**本文仅代表原作者观点,不构成任何投资意见或建议。

免责声明:文章版权归原作者所有,其内容与观点不代表Unitimes立场,亦不构成任何投资意见或建议。

388

相关文章推荐

未登录头像

暂无评论